The Castle Doctrine Forums

Discuss the massively-multiplayer home defense game.

You are not logged in.

#1 2013-06-22 12:22:05

jasonrohrer
Administrator
Registered: 2013-04-01
Posts: 1,231

Server bug fixed, Restored from backup

A server-side bug was causing robberies to fail starting at about 5pm Los Angeles time on Friday, June 21.

The bug has been fixed, and the database has been rolled back to the last known good backup (7pm LA time on Thursday, June 20). 

This will mean that some people may have lost work, paintings, or money from activities that occurred on Friday.  I'm sorry about this.  But it does effect everyone evenly and fairly (it's like the whole world entered a time machine together).

Offline

#2 2013-06-22 12:32:22

bey bey
Member
Registered: 2013-04-20
Posts: 386

Re: Server bug fixed, Restored from backup

Great thing: Old paintings are back.

Better thing: Exact backpack prepped for big heist back - hasta la vista Mr Smithsta.

HORRIBLE RESULT: Now I have a horribly ugly painting I can't get rid off permanently stuck to the formerly beautiful lower side of my screen. WHY OH WHY do the ugly ones always show up on top?! I have TEN pretty ones... *weeps*

Last edited by bey bey (2013-06-22 12:33:52)


In fact you can be batman.
(if he robbed houses and murdered families.)
- Dalleck

Offline

#3 2013-06-22 12:59:02

dalleck
Member
Registered: 2013-04-13
Posts: 250

Re: Server bug fixed, Restored from backup

bey bey wrote:

Great thing: Old paintings are back.

Better thing: Exact backpack prepped for big heist back - hasta la vista Mr Smithsta.

HORRIBLE RESULT: Now I have a horribly ugly painting I can't get rid off permanently stuck to the formerly beautiful lower side of my screen. WHY OH WHY do the ugly ones always show up on top?! I have TEN pretty ones... *weeps*

Poo to you bey bey, and your evil time-travelling shenanigans!


The rich aren't safe. Nobody is safe. -jere                   ...but the smell wafts out from the pit, obviously. - Jason Rohrer

And the more dickish they are, the more I feel like beating a house to destruction after finally figuring it out. -bey bey

Offline

#4 2013-06-22 13:20:20

bey bey
Member
Registered: 2013-04-20
Posts: 386

Re: Server bug fixed, Restored from backup

original.jpg

Last edited by bey bey (2013-06-22 13:22:26)


In fact you can be batman.
(if he robbed houses and murdered families.)
- Dalleck

Offline

#5 2013-06-22 21:20:20

Ludicrosity
Member
From: US
Registered: 2013-06-22
Posts: 144

Re: Server bug fixed, Restored from backup

Hi,

I'm sorry to start out with such a bummer of a first post, but here goes...

Unfortunately, ever since the server fix, I have been unable to load or play the game at all. When I started the game this afternoon, it tried to load up and connect to the server, but then crashed. I received a standard looking Windows message saying the program had crashed. I tried again, but this time it just froze completely when trying to connect to the server. I let it sit there for a few minutes while I tended to some stuff in another room and then closed it via Alt+F4 when I got back and it was still frozen. (It was at the black screen with little white boxes in the top right corner - the boxes were not animated though, just frozen in their current state.) I tried deleting the game completely and downloaded a fresh install, but ran into the same problem: the game simply froze up when trying to start.

I was still waiting for the registration email for these forums to send me my password so I could post at this point, so I started browsing the web while I waited. A couple minutes later... I receive the infamous "blue screen of death." I have no idea whether this was at all related to the issues with the Castle Doctrine, but I have never experienced (or even seen in real life) the blue screen of death on any computer I've had in my entire life. After restarting my computer, Windows loaded up without any problems. I copied down the error codes it gave me and searched them on Google, but nothing particularly helpful came up.

Anyway, back to the game... I tried running it once more (call me crazy, but I really wanted to play). No luck. It just froze up again on startup. At this point I figured I should try it on another computer, so I downloaded it again from another computer and started it up... Exact same issue (minus the blue screen). The first time I start it, it crashes, and a Windows error message pops up. The second time I try to run it, it simply freezes on startup. I deleted it and turned the other computer off.

It looks like it seems to work fine for everyone else, and it did work fine for me before the server fix. So does anyone have any idea what might be the issue? Thanks for any suggestions.

Offline

#6 2013-06-23 13:39:40

jasonrohrer
Administrator
Registered: 2013-04-01
Posts: 1,231

Re: Server bug fixed, Restored from backup

Oh goodness!

Seems like you may have been the one unlucky soul who was still logged into the game in the middle of the update.  I thought I checked the server to make sure that no one was logged in, but I must have missed you.

Anyway, looks like you may have died right in the middle of the update, causing your house map to become corrupted.

I've rolled you back to your state from before the update (7pm Thursday night).  Your account should be back in action now.

Sorry for the trouble!

Offline

#7 2013-06-23 20:05:03

Ludicrosity
Member
From: US
Registered: 2013-06-22
Posts: 144

Re: Server bug fixed, Restored from backup

Thanks, everything seems to be fixed now. I appreciate the help!

Offline

Board footer

Powered by FluxBB 1.5.8